TS-400 - Installing Drivers

Post questions, share ideas and techniques relating to 3D prototyping and milling
Post Reply
dpenfold
Member
Posts: 3
Joined: Tue Mar 05, 2019 4:57 pm

TS-400 - Installing Drivers

Post by dpenfold » Tue Mar 12, 2019 1:35 pm

Hi Hopefully someone out there can help me with an issue I'm having.

I'm having trouble installing drivers for the TechSoft TS-400 Milling machine, we didn't get anything with the machine besides manuals and being told "some hardware fault with this machine". We're trying to assess the machine but we can't get the drivers installed to see what we can and can't do with the machine.

At first I was using a windows 10 laptop, tried googling for drivers thought we had some luck but he kept giving me errors about Windows 7/USB (I'll try and get screenshot soon), googling that error only brought me information about printers and suggesting copying settings from a working computer (not possible).

After few tries I called up techsoft and the directed me to the Roland site and suggested drivers of the same model/type etc. again no such luck but was advised to try on an older windows as it is an old machine.

So I use a laptop with Windows XP and I get the same errors (including one about Windows 7?!)

Drivers that I've got;
"Software Package for Picza Modela Modela Pro Camm 2 Camm 3 Rotocamm V3.4 (Old)"
"TS-30 DT1" (it has a drop down option which list TS-400)
And drives from - http://download.rolanddg.jp/en/3d.html#egx4600
for Windows 10/8/7 x64 bit and Windows xp x32 bit

Before I give techsoft another call I was hoping to see if someone here had any luck or suggestions.

If anyone can I'll be very grateful! :)

User avatar
Kai Perry
Moderator
Posts: 2897
Joined: Wed Aug 03, 2011 3:59 pm
Location: Clevedon
Contact:

Re: TS-400 - Installing Drivers

Post by Kai Perry » Wed Mar 13, 2019 10:06 am

Contact the RolandCare team on 01275 335540, they can send you the driver.

Due to the age of the machine it is only supported on Windows XP.
Kai Perry
Application Engineer
Roland DG (UK) Ltd
http://www.rolanddg.co.uk

paolo8453
Silver Member
Posts: 104
Joined: Sat Feb 25, 2012 11:27 am

Re: TS-400 - Installing Drivers

Post by paolo8453 » Tue Mar 19, 2019 12:23 pm

Did you get sorted? I have most TS-400 related software backed up somewhere...
Hardware: TS-400 which seems to be the same as an EGX-400/600...

dpenfold
Member
Posts: 3
Joined: Tue Mar 05, 2019 4:57 pm

Re: TS-400 - Installing Drivers

Post by dpenfold » Tue Mar 19, 2019 12:26 pm

paolo8453 wrote:
Tue Mar 19, 2019 12:23 pm
Did you get sorted? I have most TS-400 related software backed up somewhere...
Not yet, been busy at work. IF you can find them great! If not then I can call the RolandCare when I get chance :)
Kai Perry wrote:
Wed Mar 13, 2019 10:06 am
Contact the RolandCare team on 01275 335540, they can send you the driver.

Due to the age of the machine it is only supported on Windows XP.
Thanks I'll give them a call soon if Paolo8453 software doesn't pan out lol

paolo8453
Silver Member
Posts: 104
Joined: Sat Feb 25, 2012 11:27 am

Re: TS-400 - Installing Drivers

Post by paolo8453 » Wed Mar 20, 2019 12:45 am

Messaged you...
Hardware: TS-400 which seems to be the same as an EGX-400/600...

dpenfold
Member
Posts: 3
Joined: Tue Mar 05, 2019 4:57 pm

Re: TS-400 - Installing Drivers

Post by dpenfold » Thu Mar 21, 2019 1:14 pm

Thank you to all, the machine is alive and moving around.

Just need to do a few test peaces (and get some cutters) and see how it looks. Thanks again everyone :)!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests